Author Topic: Atari ST(E) DMA top speed, new, cheap CF adapter project  (Read 22972 times)

0 Members and 1 Guest are viewing this topic.

Offline exxos_uk

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Join Date: Sep 2013
  • Posts: 7
Re: Atari ST(E) DMA top speed, new, cheap CF adapter project
« Reply #30 on: 11-09-2013, 10:15:55 »
Yes the ACSI port connectors are impossible to find here in UK :(

pins 17 & 18 on the pcb, counting from left on the CF adapter, I assume those are connected ? there is not a ratsnest connection for it, so I dont know if it supposed to be connected or a mistake ?

If you have the ratsnest version maybe I can try to reduce the number of vias...

I can get the pcbs made, maybe we can work something out ?


Offline exxos_uk

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Join Date: Sep 2013
  • Posts: 7
Re: Atari ST(E) DMA top speed, new, cheap CF adapter project
« Reply #31 on: 16-09-2013, 13:53:27 »
Adapter needs of course special driver SW. What I have. Autoboot works not without TOS mod. - it is normal, because it works not via standard ACSI protocol. I have code for it, what can be added to any TOS version. Without TOS mod is best to load driver from floppy AUTO folder.
Adapter and driver SW works fine in TOS 1.02 - 2.06 (1.04 min. is recommended).

Would the TOS mod prevent other hard drives from working and booting ?

Offline Petari

  • Administrator
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 56
  • Join Date: Aug 2010
  • Posts: 609
  • Country: 00
Re: Atari ST(E) DMA top speed, new, cheap CF adapter project
« Reply #32 on: 18-09-2013, 10:32:42 »
Of course not. It is additional, not long code, what loads bootsector from ACSI-CF adapter/card if it is attached. And there is some free space in all TOS versions, so nothing is removed, only added.

Offline exxos_uk

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Join Date: Sep 2013
  • Posts: 7
Re: Atari ST(E) DMA top speed, new, cheap CF adapter project
« Reply #33 on: 18-09-2013, 11:10:21 »
Thats great news :)

I got your PM, and sent a email, not sure you are getting my emails or PM's though ?