Main Menu

Recent posts

#21
Software / Re: Sundog, the frozen legacy
Last post by Petari - 19-10-2022, 11:49:17
This could be because TOS 2.06. In any case, it is very old one (2008). Will make newer v. with TOS 1.04 in RAM, state saves ...
#22
Software / Sundog, the frozen legacy
Last post by Shaoth - 18-10-2022, 21:45:19
While trying to play SUNDOG, another game I spent hours on, I quickly realized that the game was behaving strangely and was therefore not playable.
When you take the module to move in the starting city, the blocks change at each vertical move, causing a scrolling and you have the real or not impression to be in another city...
I play on a MegaSTE with 4Mb of memory and TOS 2.06
#23
Software / Re: Games aka list
Last post by TheNameOfTheGame - 18-10-2022, 01:05:23
Found another one:

Global Commander aka The Armageddon Man
#24
Software / Re: New game adaptations
Last post by Petari - 17-10-2022, 14:51:34
#25
Software / Re: Hatari emulation problems...
Last post by Petari - 15-10-2022, 10:21:01
While I worked on updating hard disk image with games (size 3.5 GB) - and sadly, only Hatari is good for that - or using USB reader with Windows , Total Commander for file copies (it can be set to not use Windows LFN).
Steem and Steem SSE have size limits (1 and 2 GB) .
So, I used latest Hatari 2.4.1 Windows 64 . And experienced bugs - yes, they are bugs in exact meaning of that term:
If there are in DIR for GEMDOS emulation files with names like:  GAMELIST.TXT,  GAMELISTOKT14.TXT, GAMELISTSEP24.TXT  it all will appear under emulated Atari as just GAMELIST.TXT - 3 times .  Then I copied wanted file by looking it's length - and surprise - Hatari copied other file ! So, only reliable way is to avoid LFN.  Steem 3.2 (from like 2006) does it much better - it shows LFN names like GAME~001.TXT, GAME~002.TXT ...  As Total Commander does when is set to not use LFN .
 And one more:  when I finished with all updates of hard disk image went on saving that state - to avoid getting in settings when start Hatari again, to be there at next start. And when clicked on Restore - Memory state , got message that save is incompatible with this Hatari version - while made it with it. And some bad characters lower, like *`.<   .
Well, all this mean for me that they don't care really for compatibility with original TOS versions. What is visible by pushing EmuTOS wherever can - it is set as default in Hatari. Sure, when I will want to use some better OS than TOS maybe I will use not only better OS, but better HW too - like 5000x faster PC, with like 3000x more RAM .
#26
Software / Re: New game adaptations
Last post by dakidski - 14-10-2022, 10:11:04
Wonderful new games, thank you very much.
#27
Hi everyone, I am the "vlogger" (Val Rousseau). So, I used Petari's French HDD version on the emulator Hatari v2.2.1, running under Ubuntu 20.04. I tried several TOS, and one that allowed me to run the game is TOS 1.04. As I mentioned, I get attacked as soon as the game starts, even before meeting the contact in the bathroom. But, after trying several times, I was able to escape this attack without being too much injured, I rushed to the pharmacy, got healed, then rushed to go get force fields. From there, I was able to search for Merigo, found him, killed him, and used his key to go to the maze. And there, as with all other cracked versions, I got stuck after crossing the the last door (which in the PC version leads to the room where Lydia has to use her jewel). One could argue that the maze might be different in the ST version, but I rebuild the map entirely, and it is exactly the same as in the PC version. I tried all doors. Either we can go through (then I extend my map), or we instantly die, or the door doesn't open. There could be a key or a card to use for this door, but nobody has ever mentioned such a thing, so I believe there is something wrong there.
#28
Software / Re: New game adaptations
Last post by TheNameOfTheGame - 12-10-2022, 12:45:09
Thanks, some good games there!
#29
Software / Re: New game adaptations
Last post by Petari - 12-10-2022, 09:06:35
Vengeance of Excalibur  More magic sword adv.

Guardian Angel  aka  Freddy Hardest in South Manhattan

Universe 3  Diplomatic mission

Bimbo Story  something original
#30
Well, I got e-mail from Val Rousseau today. Without any description of config on which it happens. I answered him that I myself played it for some 10 minutes, so that 2-3 second attack from start is really not something what happens. And to add - did not see such thing in any game - OK, maybe there is one exception, and funny thing, first video game I ever saw:  Pong - it was in 1979 - I made myself it using that AY chip, made TV output, control handle circuits ...  I guess if computer or other player starts
 game, it will be less than 2 seconds from start when he shoots the ball :-)


And something I experienced today:  game  Vengeance of Excalibur: it was published on 5 floppies. In 3 languages - English, French and German. After some struggle, I made English version to work from single floppy image file on hard disk. It is 1.8 MB for 1 language v. There is some bad code, what needed correction. And English v. now works fine from hard disk (2 MB min), as game needs 1 MB when run from floppies. But stupid thing is that it will not warn immediately after start on 512 KB that is is not enough, but will get some memory loc. error when start play - from saved game or as new game. Not well done.
And I can not make French and German v. to work from single image - after play start will get message Error 34, and that's end.   Btw. only 3 files differ between them and Eng. version - main exec and 2 files which contain test.  I guess again some silly code is the problem. Will be very hard to trace.
And 'best' thing: some could consider it as bug in HDD version. Nope. There are zillion ways to code it so bad that just fail from hard disk/RAM disk or whatever. And no, I don't talk about copy protection.