Atari STf TOS upgrade to 2.06 using internal IDE card - Please help

Started by tabajaralabs, 24-03-2014, 06:13:37

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Greetings from Brazil! :)

First, thanks to PPera and Popsel for the great board that is the internal IDE board :)

This board has the flashable TOS option, but I just don't want it. I just want to upgrade my 1040STf to TOS 2.06 and it is done. So, I took the schematics of the writable flash module, and connected a pair of 27C010 EPROMs in the following way:

- A16 on eprom went to A16 on the motherboard
- /CE on eprom went to /CER on the IDE board
- /OE on eprom went to RW on the IDE board (with and without a pullup)

And nothing worked :(

Of course, I got 3 different versions of TOS 2.06, used binsplit to create Even/Odd files, inverted the placement of EPROMs thinking the program could have created Odd/Even in place of Even/Odd, and like. No cigar. Burned 3 different GALs, using a Beeprog programmer. No luck.

The IDE is working like a charm. An interesting info is that I saw no activity on the RW line (which is understandable since there are no writes being conducted, and in my point of view it could be even grounded). Also, the /ROM2 is correctly connected as far as I can see. All the pins of the IDE board are correctly connected to the 68000 CPU. I know there is a jumper that puts the /rom2 line tied to vcc, but afaik it should be unconnected (and it is)

What am I doing wrong? There must be a "catch" that I'm not seeing.

Thanks a lot
Alexandre :)


You need to connect /ROM2 signal from glue to logic - hopefully it is OK.
Connect /OE of EPROMs to GND.
See on this page what is diff. when using EPROMs and Flash EPROMs:


Hmmm...I tried to understand but I was unable to get there.
Am I wrong, or there is something else than I did?
The /ROM2 is connected on the IDE PCB
/OE from EPROM is connected to GND
/CE from EPROM is connected to /CER

Won't I need to use the RW signal from the IDE board?

Thanks, and sorry for the newbieness...


No need for R/W signal - you can not write EPROMs in Atari. That signal is only for Flash EPROMs. It is high when read is in case - and then EPROM will never give data to output, since /OE is low active.

See latest 2 schematics on page linked .


Just to be sure I wasn't doing anything wrong, I disassembled everything, tried with 1.04 EPROMs (working OK), reassembled everything doing step-by-step.
- Ide on place and workig
- Two burned EPROMs using TOS 2.06 splitted in odd/even
- /OE (pin 22) to ground
- /CE (pin 20) to /CER on the IDE board
- /ROM2 pin of the ide board going to pin 12 of U68 (74LS11)

And it doesn't work :(

I'm sure this is my error and I'm missing something, but I still cannot find it. Any tips?



More info:
- The board is wired just like the photo of "ATARI ST FLASHABLE TOS EXPANSION GUIDE.pdf", pag. 9. The wire goes to the same spot on board.
- The CE jumper on board is disconnected as stated (if the atari has 2 roms, disconnect the jumper, pag. 8)
- I tried - again - to switch sides of eproms (odd/even)
- I cannot see on scope any activity on /CER pin of the IDE board
- Nor I can see any activity on pin 19 of glue IC

Is there a chance this pin is fried by any chance?