Author Topic: Problem with TOS/DOS compatible hard disk image  (Read 14799 times)

0 Members and 1 Guest are viewing this topic.

Offline STmartin

  • Newbie
  • *
  • Thank You
  • -Given: 3
  • -Receive: 0
  • Join Date: Feb 2011
  • Posts: 29
  • Gender: Male
Problem with TOS/DOS compatible hard disk image
« on: 14-04-2011, 16:11:43 »
Hi!

I have a problem with TOS/DOS compatible 2GB image, which i wrote into 2 GB SD card for my Satandisk. I can't copy anything from partition C to other partitions on Atari :( And I can't save gamex game states. What it might be, and how to repair it?
My Atari computers:
-Atari 520 STE, 4 MB RAM, TOS 1.06, Satandisk, SM 144 monitor
-Atari 1040 STFM, 1 MB RAM, TOS 1.02, SM 124 monitor


Offline Petari

  • Administrator
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 56
  • Join Date: Aug 2010
  • Posts: 653
  • Country: 00
Re: Problem with TOS/DOS compatible hard disk image
« Reply #1 on: 15-04-2011, 13:08:34 »
Obviously writing works not from some reason. Check first the most trivial thing: isn't write disabling small tab moved accidently into write disabled pos on SD card ?
If it is OK, then it is likely some incompatibility of Satandisk and your card. What is exact SD card brand and type ?
« Last Edit: 15-04-2011, 13:12:13 by Petari »

Offline STmartin

  • Newbie
  • *
  • Thank You
  • -Given: 3
  • -Receive: 0
  • Join Date: Feb 2011
  • Posts: 29
  • Gender: Male
Re: Problem with TOS/DOS compatible hard disk image
« Reply #2 on: 15-04-2011, 14:49:48 »
The card is unlocked. Writing is not disabled. My card is Integral 2 GB SD memory card
My Atari computers:
-Atari 520 STE, 4 MB RAM, TOS 1.06, Satandisk, SM 144 monitor
-Atari 1040 STFM, 1 MB RAM, TOS 1.02, SM 124 monitor

Offline Petari

  • Administrator
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 56
  • Join Date: Aug 2010
  • Posts: 653
  • Country: 00
Re: Problem with TOS/DOS compatible hard disk image
« Reply #3 on: 15-04-2011, 17:05:47 »
I checked 2GB file today with Satandisk attached to STE. Writing and copying to part E worked fine. Card is Kingston.
So, it seems that Integral and Satan don't understand each other.

Offline STmartin

  • Newbie
  • *
  • Thank You
  • -Given: 3
  • -Receive: 0
  • Join Date: Feb 2011
  • Posts: 29
  • Gender: Male
Re: Problem with TOS/DOS compatible hard disk image
« Reply #4 on: 15-04-2011, 17:45:28 »
What a shame :( I bought it yesterday for my Satan and it not works :(

PS: Copying single file worked well, but copying a folder with files is don't working
My Atari computers:
-Atari 520 STE, 4 MB RAM, TOS 1.06, Satandisk, SM 144 monitor
-Atari 1040 STFM, 1 MB RAM, TOS 1.02, SM 124 monitor

Offline Petari

  • Administrator
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 56
  • Join Date: Aug 2010
  • Posts: 653
  • Country: 00
Re: Problem with TOS/DOS compatible hard disk image
« Reply #5 on: 15-04-2011, 17:51:17 »
I saw some very poor quality SD cards, and even fake ones - marked as 4 GB, but only 2 GB, and that one died after 4-5 writings, btw.
I can only advice that avoid cheap and unknown brand.

Not much likely: your power supply may be too weak for Satandisk when it writes - then more power is required. But you'd need some voltage meter to check is there too much drop by writing.

Offline STmartin

  • Newbie
  • *
  • Thank You
  • -Given: 3
  • -Receive: 0
  • Join Date: Feb 2011
  • Posts: 29
  • Gender: Male
Re: Problem with TOS/DOS compatible hard disk image
« Reply #6 on: 15-04-2011, 17:54:48 »
My power supply is very old, but it works good. It works well with my Satan with 256 MB card partitioned with Hddriver. So probably it's something with this card.
« Last Edit: 15-04-2011, 18:11:44 by STmartin »
My Atari computers:
-Atari 520 STE, 4 MB RAM, TOS 1.06, Satandisk, SM 144 monitor
-Atari 1040 STFM, 1 MB RAM, TOS 1.02, SM 124 monitor

Offline Anemos

  • Full Member
  • ***
  • Thank You
  • -Given: 16
  • -Receive: 6
  • Join Date: Aug 2010
  • Posts: 172
  • Country: gr
  • Gender: Male
    • Flashback Computing
Re: Problem with TOS/DOS compatible hard disk image
« Reply #7 on: 15-04-2011, 18:18:18 »
perhaps fake memory stick .. try buy one brand name.
Other think.. try to use other card reader to write the HD image.
My system: Atari STE 4MB, OS: SuperTOS 2.06, HD: US/disk 4gb SDcard ,ppera v0.98 HD drivers, USB mouse adapter by me, PSX controller joy adapter by me,  full list of adaption,s games by Petari.
Second Atari machine: 1040 STF
Other: 2X Lilliput Atari 130 XE

Offline munchy

  • Newbie
  • *
  • Thank You
  • -Given: 2
  • -Receive: 0
  • Join Date: Dec 2010
  • Posts: 41
Re: Problem with TOS/DOS compatible hard disk image
« Reply #8 on: 15-04-2011, 22:52:36 »
I have had success with sandisk,kingston and kodak cards.I Would stick with sandisk for now if at all possible.I had some problems with writing images originally but all eventually worked well with petaris drive image program.

Offline STmartin

  • Newbie
  • *
  • Thank You
  • -Given: 3
  • -Receive: 0
  • Join Date: Feb 2011
  • Posts: 29
  • Gender: Male
Re: Problem with TOS/DOS compatible hard disk image
« Reply #9 on: 16-04-2011, 12:17:07 »
OK, I will try it with another card. Thanks!

Regards
STmartin
My Atari computers:
-Atari 520 STE, 4 MB RAM, TOS 1.06, Satandisk, SM 144 monitor
-Atari 1040 STFM, 1 MB RAM, TOS 1.02, SM 124 monitor

Offline STmartin

  • Newbie
  • *
  • Thank You
  • -Given: 3
  • -Receive: 0
  • Join Date: Feb 2011
  • Posts: 29
  • Gender: Male
Re: Problem with TOS/DOS compatible hard disk image
« Reply #10 on: 16-04-2011, 20:31:02 »
Bad news :(

I wrote 2 GB image to the Kingston 2 GB card and writing isn't working properly too :( So it's problem in something else. How to solve this problem?

PS: I'm writing images under Win XP, and I'm using card reader mounted in Brother DCP-165C printer for it. And my Atari STE has 4 MB RAM and TOS 1.06
« Last Edit: 17-04-2011, 09:49:52 by STmartin »
My Atari computers:
-Atari 520 STE, 4 MB RAM, TOS 1.06, Satandisk, SM 144 monitor
-Atari 1040 STFM, 1 MB RAM, TOS 1.02, SM 124 monitor

Offline Anemos

  • Full Member
  • ***
  • Thank You
  • -Given: 16
  • -Receive: 6
  • Join Date: Aug 2010
  • Posts: 172
  • Country: gr
  • Gender: Male
    • Flashback Computing
Re: Problem with TOS/DOS compatible hard disk image
« Reply #11 on: 17-04-2011, 21:08:52 »
ok,99% is card reader problem,(not supporting Drive-imaging program) have seen like that before..im using MicroSD card 2gb,4gb ect..with a small USB stick reader,and working perfect with Drive-imaging..
the default 3.5" deck multi reader on my PC is not working for this.
Test other type card reader.
My system: Atari STE 4MB, OS: SuperTOS 2.06, HD: US/disk 4gb SDcard ,ppera v0.98 HD drivers, USB mouse adapter by me, PSX controller joy adapter by me,  full list of adaption,s games by Petari.
Second Atari machine: 1040 STF
Other: 2X Lilliput Atari 130 XE

Offline Petari

  • Administrator
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 56
  • Join Date: Aug 2010
  • Posts: 653
  • Country: 00
Re: Problem with TOS/DOS compatible hard disk image
« Reply #12 on: 18-04-2011, 12:19:24 »
This is interesting.  Maybe the problem is old firmware in Satandisk ? Jookie made some updates during time. But to change firmware you need some special cable and header (connector). I need to check some things, as how to read out current firmware version ...  Will back later ...

Offline STmartin

  • Newbie
  • *
  • Thank You
  • -Given: 3
  • -Receive: 0
  • Join Date: Feb 2011
  • Posts: 29
  • Gender: Male
Re: Problem with TOS/DOS compatible hard disk image
« Reply #13 on: 18-04-2011, 14:58:00 »
OK, I will wait for you. In the meantime I will buy another card reader and I will try to write this image with it.
« Last Edit: 18-04-2011, 14:59:47 by STmartin »
My Atari computers:
-Atari 520 STE, 4 MB RAM, TOS 1.06, Satandisk, SM 144 monitor
-Atari 1040 STFM, 1 MB RAM, TOS 1.02, SM 124 monitor

Offline Petari

  • Administrator
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 56
  • Join Date: Aug 2010
  • Posts: 653
  • Country: 00
Re: Problem with TOS/DOS compatible hard disk image
« Reply #14 on: 19-04-2011, 14:20:45 »
Nothing so far about how to see Satandisk FW version.
It would be good to check is writing works with 1GB image file (with games, driver). It has different driver - basic ACSI and not ICD command set. If it will work, thin we will know that problem is with ICD command set support by writing.