Author Topic: Mega STE not a STE?  (Read 4525 times)

0 Members and 1 Guest are viewing this topic.

Offline ataricrypt

  • Jr. Member
  • **
  • Thank You
  • -Given: 8
  • -Receive: 1
  • Join Date: Sep 2015
  • Posts: 75
  • Country: gb
  • Gender: Male
  • AtariCrypt
    • AtariCrypt
Mega STE not a STE?
« on: 18-12-2015, 12:52:56 »
Hello all, I'm lucky enough to own a Mega STe and recently I've noticed that a few apps don't seem to recognise this as a STE model, so then quit. For example, I've just downloaded 'Paula' and it fails with the error message: "Paula needs the STE-DMA sound hardware.."

Of course it has DMA audio - my Mega is playing a stereo MOD music right at this very moment. lol
So I'm assuming apps like this (and the Sound.CPX , BackTrack v4.04 and also ProTracker by Wizzcat/Delta Force) have some sort of machine identification check in their software code? Perhaps this is looking for the standard STE or maybe a TT too. I imagine the programmers didn't know how to check for the Mega STE as they're quite rare??

It's a bit annoying - so is there a way around this?
Does Paula work on anyone's Mega here? I downloaded my copy from Atari Mania :
http://www.atarimania.com/utility-atari-st-paula_29702.html

FWIW - I have a stock Mega STe with 4mb ram and Tos 2.06

Thanks :-)
Steve
« Last Edit: 18-12-2015, 20:04:53 by ataricrypt »
AtariCrypt . . stay cool & stay ATARI ST
Atari MEGA STe | Atari STe | MiNT OS 1-19 Aranym OS X


Offline Petari

  • Administrator
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 56
  • Join Date: Aug 2010
  • Posts: 653
  • Country: 00
Re: Mega STE not a STE?
« Reply #1 on: 21-12-2015, 22:01:57 »
I tried Paula on Mega STE (TOS 2.06) and TT and it works well on both.
Mega STE is pretty much same as STE, with some add-ons.  If some STE SW works not on Mega STE it is for sure bad code.  Even if SW was done before Mega STE is released it should use smart enough HW detection to allow it working on higher models. 
If Paula 2.6 works not on your Mega STE and says no HW, it may be some failure.  I just copied files from floppy image to SD card, and started.

Offline ataricrypt

  • Jr. Member
  • **
  • Thank You
  • -Given: 8
  • -Receive: 1
  • Join Date: Sep 2015
  • Posts: 75
  • Country: gb
  • Gender: Male
  • AtariCrypt
    • AtariCrypt
Re: Mega STE not a STE?
« Reply #2 on: 22-12-2015, 11:00:51 »
Really? Now I am confused then as to why my Mega STe doesn't like this app.
Did you try Sound.cpx or the others I mentioned? I'm worried now as to why apps like Paula won't even run..  Do you have anything in the AUTO folder or ACCs / CPXs?

fwiw - my hard drive died yesterday so I cannot test this until the ultra satan arrives in the new year.
I'll then try Paula again properly. I'll send you a screen shot of the error too lol

Thanks for the reply, appreciated.
Steve

Also, there's another user having similar troubles. Like with sound.cpx
http://atariage.com/forums/topic/245167-mega-ste-no-stereo-sound-no-dma/
« Last Edit: 22-12-2015, 12:26:48 by ataricrypt »
AtariCrypt . . stay cool & stay ATARI ST
Atari MEGA STe | Atari STe | MiNT OS 1-19 Aranym OS X

Offline Petari

  • Administrator
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 56
  • Join Date: Aug 2010
  • Posts: 653
  • Country: 00
Re: Mega STE not a STE?
« Reply #3 on: 22-12-2015, 13:18:30 »
You can try it by running from floppy - what is good to exclude CPX problems too.
No any ACC, CPX , AUTO by me - they just make confusion.

Offline ataricrypt

  • Jr. Member
  • **
  • Thank You
  • -Given: 8
  • -Receive: 1
  • Join Date: Sep 2015
  • Posts: 75
  • Country: gb
  • Gender: Male
  • AtariCrypt
    • AtariCrypt
Re: Mega STE not a STE?
« Reply #4 on: 22-12-2015, 13:29:48 »
Okay, I've just tried both Paula and ProTracker on a clean TOS from floppy and they both failed.
I'm gutted :-(

btw, did you try the URL in my last reply above?

Anyhow, I can't wait to get the Ultra Satan as it's a real step back in time using just floppy disks lol
Thanks for the help PP. Appreciated.
Steve
« Last Edit: 22-12-2015, 13:53:41 by ataricrypt »
AtariCrypt . . stay cool & stay ATARI ST
Atari MEGA STe | Atari STe | MiNT OS 1-19 Aranym OS X

Offline ataricrypt

  • Jr. Member
  • **
  • Thank You
  • -Given: 8
  • -Receive: 1
  • Join Date: Sep 2015
  • Posts: 75
  • Country: gb
  • Gender: Male
  • AtariCrypt
    • AtariCrypt
Re: Mega STE not a STE?
« Reply #5 on: 22-12-2015, 14:02:05 »
Okay, just emailed you some pictures to prove these two apps fail on my Mega STe.. ..
I've just copied both over to a newly formatted floppy and Cold Booted. Nothing in the OS at all and both still fail.

Extremely gutted  ???  :'(
AtariCrypt . . stay cool & stay ATARI ST
Atari MEGA STe | Atari STe | MiNT OS 1-19 Aranym OS X