Author Topic: Mega ST2 FTOSx4 & IDE problems  (Read 1952 times)

0 Members and 1 Guest are viewing this topic.

Offline neogain

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Join Date: Mar 2015
  • Posts: 2
  • Country: de
Mega ST2 FTOSx4 & IDE problems
« on: 07-04-2015, 18:01:37 »
Hello,

i build the FTOSx4 and IDE Interface for the Mega ST2. Before i build this too with Success for the ATARI STfm Rev. D. But i have now some Issuess with the Mega ST2 and the FTOS. IDE alone works, that's not the Problem. But if i plug in the FTOS PCB, the Mega ST2 won't able to boot. I changed the W4 Settings (Makes a Jumper) and cut the Output PIN 12 (74LS11), but it still don't work. Is here anything diffrent as the 1040STfm Models? Because, it testet the new PCB's in the 1040STfm and it still works.

If some more information required, let me know...

Thanks, Neogain



Offline Petari

  • Administrator
  • *****
  • Thank You
  • -Given: 2
  • -Receive: 56
  • Join Date: Aug 2010
  • Posts: 611
  • Country: 00
Re: Mega ST2 FTOSx4 & IDE problems
« Reply #1 on: 09-04-2015, 09:55:36 »
Quote from page about this mod:

" On pic above is how it is solved in Mega ST. 32-pin sockets are inserted in original ROM sockets, so that pins 1, 2, 31, 32 are in air. Pins 30 are cut down, and is best to put little insulator between them and sockets, to avoid contact.

Connectiing of Flash EPROMs:   pin 32:   +5V (Vcc) , add cer. capacitor between it and GND, with shortest possible legs.
                                                 pin 31:  (/WE)  /RW signal from CPU - via resistor and protection switch (explained later)
                                                 pin 30:  (A17 of Flash)    to selection switch
                                                 pin  2:   (A16 of Flash)    to A17 of CPU - it is closest at W2, point 3 .
                                                 pin  1:   (A18 of Flash)    to selection switch

Other connections in Mega ST:  W3 (remains) on pos for 1M ROMs (2-3 connected). W2: remove shortcut and connect point 3 to pins 2 of Flash EPROMs. To point 2 of W2 connect inverted RW signal of CPU (this leads to OE pins of ROMs) .
W4: remove shortcut (if there was 6 chip TOS), Lower point (ROM2 signal) goes to selection logic, upper point comes from selection logic - then need to cut (desolder) pin 12 of 74LS11 , to avoid conflict. "

You should check with ohmmeter all lines for proper connection and no shortcut to GND . So, does A17 from CPU goes to proper pins of FEPROMs. Signals OE and WE . All address and data lines too .

Offline neogain

  • Newbie
  • *
  • Thank You
  • -Given: 0
  • -Receive: 0
  • Join Date: Mar 2015
  • Posts: 2
  • Country: de
Re: Mega ST2 FTOSx4 & IDE problems
« Reply #2 on: 28-04-2015, 17:17:00 »
Thx Petari,

it work's. Problem was i have cut Pin12 from 74LS11. i make the connection back. i checked the Flash Function, it works like a charm now :)